×
Bevor Du postest......

Hallo und willkommen bei dieschmids.at!
Bevor du hier ein Problem loswerden möchtest, lies bitte einmal das: https://www.dieschmids.at/forum/15-hilfe-wie-geht-das/48983-wo-finde-ich-was
und das: https://www.dieschmids.at/forum/15-hilfe-wie-geht-das/40656-du-hast-eine-frage-ans-forum
Aber dann kann es los gehen. Wir freuen uns über deinen Besuch!

× Routermodelle: TG 789, TG 788, TG 670, TG 588

normal Frage TG588v - bekomme nichts durch die Firewall


Mehr
07 Sep 2018 14:48 #76691 von sulla
Liebe Gemeinde!

Ich habe ein Problem, einen SSH-Server hinter dem TG588v aus dem Internet zu erreichen.

setup:
A1 Wlan Box: TG588v, firmware, externe IP: A.B.C.D, WLAN aktiv
port 1: Raspberry mit Raspbian mit SSH-Server port 22, iP:10.0.0.6 fixiert am Router

Konfiguration: Ich habe
die A1 Wlan Box mit Hardware Knopf resettet
an der A1 Wlan Box die IP-Adresse des Servers fixiert
mit "gemeinsame Nutzung von Spielen" port 22 an den SSH-Server weitergeleitet
den SSH-Server sogar in die DMZ gestellt

ich habe geprüft:
Wenn ich mit meinem Laptop im WLAN hänge und also aus dem intranet den SSH Server mit 10.0.0.6 anwähle, läuft alles, logisch. ==> SSH-Server funktioniert
Ich sehe an der A1WlanBox im "Verbindungsstatus" nichts, was ok ist, die Verbindung läuft ja an der Box vorbei direkt von Client zu Server im Intranet.

Fremde SSH-Server im Internet kann ich vom Laptop aus anwählen ==> SSH-Client am Laptop geht



ich habe folgendes "Phänomen":
1) Wenn ich mit dem Laptop im WLAN hänge und also AUS DEM INTRANET den SSH-Server mit A.B.C.D anwähle, läuft alles!
Ich sehe im "Verbindungsstatus" die ausgehende und die eingehende Verbindung:
ausgehend:
Protokoll: tcp(6)
LAN: 10.0.0.14:59529 (das ist die IP des Laptops)
A1 WLAN Box: A.B.C.D:49302
WAN: A.B.C.D:22 (==> OK, die Anfrage sollte also an die Box selbst gehn, auf port 22)
WAN-Status: HERGESTELLT
Internet-Schnittstelle: vINTERNET
Richtung: Outgoing
Markierungen: I..L.........

und die eingehende Verbindung lautet:

Protokoll: tcp(6)
LAN: 10.0.0.6:22
A1 WLAN Box: A.B.C.D:22
WAN: A.B.C.D:49302 (das ist dasselbe wie die ausgehende Verbindung)
WAN-Status: HERGESTELLT
Internet-Schnittstelle: LocalNetwork
Richtung: Eingehend
Markierungen: I..L.........
schaut ja soweit gut aus.

2) Wenn ich mit dem Laptop das WLAN ausschalte, über SIM-Karte ins Mobilfunknetz gehe und dann also AUS DEM INTERNET den SSH-Server mit A.B.C.D anwähle, läuft..... nichts!
Die A1Box zeigt mir im "Verbindungsstatus"... nichts!
Scheint so, als ob da jetzt gar nichts an der A1 Box ankäme.

andere Dienste wie IMAPs oder SMTPs gehn auch nicht.

Ich habe keine Ahnung, was da falsch läuft, kann mir da jemand beistehn?
Danke,
Sulla

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
07 Sep 2018 14:53 - 07 Sep 2018 15:31 #76692 von sulla
Ach ja, vergessen zu sagen:
Firewall am A1 Modem ist "Standard", d.h. die Portweiterleitung für Spiele sollte aktiv sein. Aber auch "Transparent" bringt nix.
PPP Modus habe ich von "Bei Bedarf" "Ein" auf "Aus" geschaltet, damit müsste das Modem always-on sein.
Letzte Änderung: 07 Sep 2018 15:31 von sulla.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
07 Sep 2018 16:17 #76693 von herby68
hallo,
verwendest du eine 588er konfiguration von uns oder wird die a1 default konfig verwendet?
bei unseren konfigs ist ssh auf disabled!

lg herby

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
07 Sep 2018 16:53 #76694 von sulla
ich verwende die A1 default config.
Aber es geht auch kein IMAPs auf port 143 durch...

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
07 Sep 2018 17:24 - 07 Sep 2018 17:52 #76695 von rwhome
hallo,

du hast keine öffentliche ip adresse
a1 macht gerne cg-nat (nat auf provider ebene)
die ip adresse am wan-port deines modems ist keine öffentliche ip adresse
das a1 modem ist daher nicht von außen erreichbar
diese ip adresse stimmt dann auch nicht überein mit der ip adresse welche z.b.
www.whatsmyip.org/ anzeigt
cg-nat ist auch zu erkennen wenn beim hostnamen nat dabeisteht
ist in diesen fall eine spezielle ip adresse welche du mit vielen anderen teilst
daher bitte eine öffentliche ip adresse bei a1 beantragen

p.s.
falls es um das aufsetzen eines mailservers geht
die von a1 zugewiesene ip adresse ist dynamisch (wechselt also) und nicht statisch
ein eigener mailserver macht damit schon mal wenig sinn
und a1 sperrt port 25 eingehend
mails via smtp wird man daher nie empfangen können
da alle mailserver mails via smtp versenden ist ein eigener mailserver so nicht realisierbar

p.s.2
habe deine ip adresse überprüft (kann ich sehen als forum moderator als zusatzinfo zu deinen beitrag)
www.geoiptool.com/
du hast im hostnamen nat dabeistehen

LG RWHome//Wer glaubt, etwas zu sein, hat aufgehört, etwas zu werden
Letzte Änderung: 07 Sep 2018 17:52 von rwhome.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
07 Sep 2018 22:31 #76697 von sulla
Oh verflixt! Danke für die Erklärung! Dann konfigurier ich mir jetzt wenigstens nicht mehr die Finger wund. Werd mal schauen, wie ich eine öffentliche IP bei A1 beantrage.

Dass die IP des Modems nicht mit der sichtbaren IP, wie Du schreibst, übereinstimmt, ist mir schon aufgefallen, hab mir da aber nix dabei gedacht - geht mir öfter so. Wird wohl langsam Zeit für IPv6...

Die wechselnde IP habe ich mit DDNS im Griff (A1 selbst bietet da diverse Dienste am Modem direkt an, ich hab no-ip genommen), das ist kein Problem. Der DDNS Dienst leitet auch richtig auf die IP des Modems um, aber die ist ja nicht die, die whatsmyip liefert.

Mein Mailserver läuft über SMTPs (port 587) und IMAPs (port 143), alles streng mit Authentifizierung und TLS. Das sollte laufen. Mailserver ist nur ein Satellitenserver, kein FQDN server mit MX record.

Außerdem brauch ich Zugriff von extern auch noch für Smarthomesystem. Man hat ja sonst keine Hobbies.

Bei UPC war das auch alles überhaupt kein Problem, alles prompt erreichbar... Bin grad umgezogen, und am neuen Wohnort gibts kein UPC...

mille grazie jedenfalls!

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Moderatoren: andifrm1912enjoyherby68benderrwhomegeko
Ladezeit der Seite: 0.682 Sekunden
Powered by Kunena Forum