normal Frage DNS, IPv6, Windows und Pi-hole


  • Vindobona
  • Vindobonas Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
Mehr
05 Apr 2019 20:53 - 05 Apr 2019 21:53 #77401 von Vindobona
Vindobona antwortete auf DNS, IPv6, Windows und Pi-hole
Zwischenbericht / Lösung Teil 1

Ich habe zwischenzeitlich meine Netzwerk-Architektur etwas geändert und den zweiten Switch (Wohnzimmer) an den ersten Switch (Arbeitszimmer) gehängt. Am Pirelli hängt somit nur mehr ein Switch an einem Ethernet-Port und die anderen Ports sind nicht belegt.

Alt:


Aktuell:



Mein HTPC war seit der Umstellung zwar nur selten in Verwendung, doch es schaut recht gut aus. Sowohl unter Windows wie auch unter Linux scheint nun alles gut und zügig zu funktionieren. Websites werden schnell geladen weil die DNS-Auflösung nun zügig und zuverlässig funktioniert - so wie es sein soll.
Ping-Zeiten zu diversen Internet-Domains sind gut (jedenfalls akzeptabel; meist in 10 - 20 ms, manchmal etwas höher aber durchaus OK).
Vor allem sind das Pirelli und der Pi-hole-Server schnell und zuverlässig mit einem Hop im Traceroute erreichbar!
user@rome:~$ date; traceroute 10.0.0.130; date
Fri Apr  5 20:02:47 CEST 2019
traceroute to 10.0.0.130 (10.0.0.130), 30 hops max, 60 byte packets
 1  torta (10.0.0.130)  0.757 ms  0.701 ms  1.064 ms
Fri Apr  5 20:02:47 CEST 2019
user@rome:~$
user@rome:~$ date; traceroute 10.0.0.138; date
Fri Apr  5 20:02:50 CEST 2019
traceroute to 10.0.0.138 (10.0.0.138), 30 hops max, 60 byte packets
 1  _gateway (10.0.0.138)  1.138 ms  1.874 ms  2.727 ms
Fri Apr  5 20:02:50 CEST 2019

Es scheint so, als wäre es vorher zu teilweisen Switching-Loops im LAN gekommen.

Ich habe, wenn ich mich recht erinnere, zwar auch das OS am Pi-hole-Server aktualisiert (auf DietPi v6.22) und auch Pi-hole selbst kurzzeitig auf einen Dev-Branch umgestellt (wegen eines Bugfixes, dann aber wieder zurückgestellt auf den Master). Auch habe ich zuvor einen Switch (ZyXEL GS-105B v3) neu gestartet.
Ich meine aber dennoch, dass das Problem durch die Änderung der Netzwerkarchitektur beseitigt wurde.


So weit, so gut. Der HTPC funktioniert nun genau so gut wie mein Haupt-PC.
Am Smartphone (WLAN via Pirelli) habe ich aber noch immer erhebliche Probleme mit der DNS-Auflösung. Vor allem direkt nach der Verbindung mit dem WLAN klappt teilweise gar nichts; nach einiger Zeit und einigen Versuchen scheint es dann (zumindest halbwegs) zu funktionieren.


Aber mein Umbau geht ja weiter.
Der aktuelle Switch im Arbeitszimmer (ZyXEL GS-105B v3) wird durch einen neuen Switch (Zyxel GS1200-8; mit IGMP-Snooping) ersetzt werden.
Das WLAN (derzeit ohnedies nur für [meine] Smartphones) wird über einen eigenen WLAN-Router (Zyxel NBG-418N v2; non-routing-mode, als Access Point) realisiert. Dann kann ich endlich auch (wieder) mehrere SSID's machen und u.a. auch wieder ein Gäste-WLAN bereitstellen.
Die Hardware liegt schon da, vielleicht mach ich es noch heute.
Dabei werde ich auch meine IP-Adressen vom "Klasse A"-Netz (10/8) auf ein "Klasse C"-Netz (192.168.1/24) ändern (u.a. deshalb, da die neuen Zyxel-Geräte das als Default haben).
BTW: Ich könnt mich schon wieder gewaltig aufregen, weil A1 die LAN-IP-Konfiguration vom Pirelli extrem einschränkt. In "Klasse A" geht nur 10.0.0/24 und in "Klasse C" nur 192.168.x/23. Diese Postler (von der blauen Post; aber auch die von der gelben Post, die es nicht für notwendig erachten, mich über die Abholmöglichkeit meiner neu bestellen Hardware zu informieren) ...
Mal schauen, wie die schlauen Telefone dann im neuen Netz funktionieren.

Geplant:



P.S.: Etwas blöd nur, dass ich den älteren Router (8 Port, v2) wohl behalten werde (weil ich bis zu 6 Ports im Wohnzimmer verwende), den neueren (nur 5 Port, v3) aber außer Betrieb nehmen werden. Was genau nun die v2 vom v3 unterscheidet weiß ich aber ohnedies nicht. Lt. Datenblätter ist der Stromverbrauch der v3-Varianten etwas geringer. Interessanterweise wird im Datenblatt für die v2-Geräte "IGMP snooping v1/v2 support (GS-105B v2)" angeführt, also nur für das 5-Port-Gerät (welches ich ohnedies nicht habe); für die v3-Geräte gibt es keinen Hinweis auf IGMP.

Dieser Beitrag enthält Bilddateien.
Bitte anmelden (oder registrieren) um sie zu sehen.

Letzte Änderung: 05 Apr 2019 21:53 von Vindobona. Begründung: Switching-Loops statt Routing-Loops

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Moderatoren: andifrm1912enjoyherby68benderrwhomegeko
Ladezeit der Seite: 0.259 Sekunden
Powered by Kunena Forum