normal Frage DNS, IPv6, Windows und Pi-hole


  • Vindobona
  • Vindobonas Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
Mehr
19 Mär 2019 23:10 - 19 Mär 2019 23:13 #77360 von Vindobona
DNS, IPv6, Windows und Pi-hole wurde erstellt von Vindobona
Ich habe leider noch Probleme mit meinem Pi-hole-Server (siehe auch Pi Hole ), möchte aber für allgemeinere Fragen, die nicht Pirelli-spezifisch sind, hier lieber ein einen eigenen Thread haben.
Ich weiß nicht, wie verbreitet Pi-hole hier bei den Usern dieses Forums ist, aber der ein oder andere hat Pi-hole wohl auch im Einsatz oder zumindest einmal ausprobiert.

Anbei ein aktuelles Beispiel für den Aufruf der Website dieschmids.at:

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.


Anm.: Die jüngsten Einträge im Log sind oben, die ältesten unten.

Die ersten Fragen hätte ich da gleich einmal zum zeitlich ersten (ältesten) Eintrag, dem "AAAA"-Eintrag. Dieser ist das IPv6-Pendant zum "A"-Type für IPv4.
Am Client (PC mit Windows 10) habe ich IPv6 für den Netzwerkadapter deaktiviert. Ist das überhaupt (noch) sinnvoll?
Wenn nun alle Clients nur IPv4 verwenden würden, wäre dann diese IPv6-Anfrage nicht überflüssig?
Könnte diese eventuell am Pi-hole deaktiviert werden? Und wäre das auch eine sinnvolle Lösung?
IPv6 selbst spielt in meinem lokalen Netz keine Rolle, und das wohl auch noch länger.
Externe Server sind, so denke ich, praktisch auch immer im IPv4-Netz erreichbar, vielleicht auch zusätzlich mit einer IPv6-Adresse.
Kann mein Windows, mit deaktiviertem IPv6 für den verwendeten Netzwerkadapter, überhaupt etwas mit einer eventuellen IPv6-Adresse für " www.dieschmids.at " anfangen?
Und wer triggert eigentlich diese "AAAA"-Anfrage? Der DNS Resolver vom Windows? Dieser arbeitet wohl dennoch auch mit IPv6, unabhängig von den jeweiligen Adaptereinstellungen (zumindest so lange irgendein Adapter auch noch IPv6 konfiguriert ist).


Weiteren Frage: Warum gibt es (fast gleichzeitig) zwei "A"-Einträge für diese Domain?
Und warum wurde der ältere, mit Status = "OK (cached)", scheinbar aus dem DNS-Cache vom Pi-hole beantwortet und der jüngere, mit Status = "OK (forwarded)", hier wohl erst nach Antwort vom DNS-Upstream-Server (in meinem Fall vom Router) beantworte? So jedenfalls interpretiere ich das Query-Log am Pi-hole.

Anm.: Dieses Verhalten ist der Normalfall für Domains am Pi-hole bei mir, die vom Browser aufgerufen werden.


Mit IPv6 bin ich noch nicht wirklich gut vertraut. IPv4 ist mir da schon näher, wobei ich da auch eher nur Kentnisse habe, wie man sie als ambitionierter Use hat/braucht. Was dann immer genau abläuft, weiß ich nicht immer. Bisher war das DNS für micht auch eher nur ein System, dass funktionierte, wenn ich die richtigen DNS-Server konfiguriert hatte.


P.S.: Pi-hole am Raspberry Pi (10.0.0.130) und PC (10.0.0.1) mit statischer IP, am gleichen Switch, welcher an meinem Pirelli-Router hängt. Einziger DNS-Upstream-Server für Pi-hole ist der Pirelli-Router (10.0.0.138).
Letzte Änderung: 19 Mär 2019 23:13 von Vindobona.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
20 Mär 2019 21:15 - 20 Mär 2019 21:29 #77361 von rwhome
rwhome antwortete auf DNS, IPv6, Windows und Pi-hole
hallo,

ich benutze pi-hole ohne große probleme
ganz selten muss eine dns anfrage wiederholt werden
hatte daher noch keinen grund für eine diagnose

umstellen kann man einiges
warum benutzt du den router als dns upstream ... lokale namensauflösung ?
wenn nicht dann setzte gleich die dns die du willst
vielleicht auch mal andere als die von a1

sofern du ein windows netzwerk hast würde ich ipv6 nicht abdrehen
man verzichtet auf einigen komfort
wenn du wirklich alles von ipv6 abdrehen willst musst in die registry abtauchen

wenn du die dns queries in realtime ansehen willst
via ssh
pihole tail
kann helfen bei der diagnose

p.s.
setze testweise eine webseite mit denen du sie meisten probleme hast mal in die whitelist
würde mich interessieren ob das was ändert

LG RWHome//Wer glaubt, etwas zu sein, hat aufgehört, etwas zu werden
Letzte Änderung: 20 Mär 2019 21:29 von rwhome.
Folgende Benutzer bedankten sich: Vindobona

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Vindobona
  • Vindobonas Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
Mehr
20 Mär 2019 22:24 #77362 von Vindobona
Vindobona antwortete auf DNS, IPv6, Windows und Pi-hole

rwhome schrieb: ich benutze pi-hole ohne große probleme
ganz selten muss eine dns anfrage wiederholt werden
hatte daher noch keinen grund für eine diagnose

OK, (fast) eine Probleme, so sollte es sein.
Ist auf meinem Haupt-PC auch so, und zwar überhaupt keine Probleme (noch festgestellt).
Aber wenn es bei dir - wenn auch nur ganz selten - vorkommt, dann ... ja was dann? Keine Ahnung, aber vielleicht entdeckst du ja irgend wann etwas.


rwhome schrieb: umstellen kann man einiges
warum benutzt du den router als dns upstream ... lokale namensauflösung ?
wenn nicht dann setzte gleich die dns die du willst
vielleicht auch mal andere als die von a1

Nein, nicht wegen lokaler Namensauflösung. Mein Pirelli war und ist z.B. auch gar nicht unter dem dort eingetragenen Hostnamen erreichbar. Früher, sehr viel früher (noch älteres Windows? ältere Firmware am Pirelli?) hatte das, wenn ich mich recht erinnere, auch mal funktioniert. Aber das stört mich gar nicht weiter und ich bin dem nie nachgegangen.
Ich hatte ursprünglich die (beiden) DNS-Server von A1 im Pi-hole eingetragen; jene, die auch der Router hat.
Dann habe ich aber umgestellt und das Pirelli eingetragen, weil ich Probleme mit der Auflösung am Smartphone hatte. Es schien auch so, dass die Probleme am Smartphone verschwunden wären (was ich noch immer glaube; habe es aber gerade nicht im WLAN). Siehe auch Beitrag im Thread Pi Hole (im Subforum "Pirelli/ADB").
Gestern gab es dann aber doch wieder erhebliche Probleme an meinem HTPC unter Win 10 (und er läuft nur ganz selten unter Win10)
Fürs erste habe ich dort mal den DNS-Cache geflusht, aber dann nichts weiter mehr gemacht.
Ich kann vielleicht mal andere DNS-Server versuchen, auch wenn ich da nicht unbedingt der Freund davon bin. Eigentlich bin ich mit den DNS-Servern von A1 eh zufrieden.
Ziel ist ohnedies ein lokaler Unbound-Server (hyperlocal). Aber vorher muss es erst mal so problemlos laufen.


rwhome schrieb: sofern du ein windows netzwerk hast würde ich ipv6 nicht abdrehen
man verzichtet auf einigen komfort
wenn du wirklich alles von ipv6 abdrehen willst musst in die registry abtauchen

Ich muss mich da noch etwas einlesen denn IPv6 habe ich bisher immer mehr oder weniger verdrängt. Ich denke, man kann aber IPv4 wenigstens bevorzugen, mit einem Registry-Eintrag; standardmäßig wird IMHO IPv6 bevorzugt.
Komfortverlust hätte ich bisher noch keinen festgestellt, zumindest wüsste ich nichts davon.
Aber vielleicht aktiviere ich IPv6 doch wieder am Netzwerkadapter.


rwhome schrieb: wenn du die dns queries in realtime ansehen willst
via ssh
pihole tail
kann helfen bei der diagnose

Ah! Im Web-/Admin-Interface gibt es unter "Tools" auch die zwei Punkte "Tail pihole.log" und "Tail pihole-FTL.log", so sehe ich aber gar nichts. Warum, weiß ich nicht. Aber direkt in der Shell funktioniert das Tail aber. Danke!


rwhome schrieb: setze testweise eine webseite mit denen du sie meisten probleme hast mal in die whitelist
würde mich interessieren ob das was ändert

Kann ich beim nächsten Mal ja probieren und schauen, ob sich da etwas ändert.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Vindobona
  • Vindobonas Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
Mehr
20 Mär 2019 22:54 #77363 von Vindobona
Vindobona antwortete auf DNS, IPv6, Windows und Pi-hole
Ich hab mir nun mal mit pihole tail angeschaut, was da geloggt wird, aber nur von meinem Haupt-PC, wo ohnedies alles funktioniert.

Aufruf der Domains via Firefox (v66.0, mit Plug-Ins uBlock Origin, uMatrix und Decentraleyes; auf Win 10).

orf.at: war schon im Cache vom Pi-hole
diepresse.com: noch nicht im Cache vom Pi-hole
keineguelitgedomain123456.at: ungültige Domain, und auch noch nicht gecacht





Bei den gültigen Domains erkennt man schön, dass immer zwei(!) "query[A]" und ein "query[AAAA]" für die Haupt-Domain ausgeführt werden. Ob das normal ist? Vielleicht hängt das mit den Plug-Ins am Browser zusammen.



Zum Unterschied Aufrufe aus SRWare Iron (v71, ohne Plugins)
orf.at: gecacht, nur ein "query[A]" und kein "query[AAAA]" für die Haupt-Domain
derstandard.at: nicht gecacht, nur ein "query[A]" und kein "query[AAAA]" für die Haupt-Domain




Iron scheint sich also schon einmal ganz anders zu verhalten, als Firefox (mit Plug-Ins). Interessant. Was immer ich davon nun halten soll.

Dieser Beitrag enthält Anhänge.
Bitte anmelden (oder registrieren) um sie zu sehen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Vindobona
  • Vindobonas Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
Mehr
25 Mär 2019 01:22 #77368 von Vindobona
Vindobona antwortete auf DNS, IPv6, Windows und Pi-hole
Leider ist doch auch mein Linux auf meinem HTPC betroffen!
Ich habe beim (irrtümlichen) Start von HexChat festgestellt, dass er den Server nicht gefunden hat. Danach habe ich das Programm gleich noch einmal gestartet, und dann war alles OK (Server/Chat gefunden).

Auch im Browser dauert die DNS-Auflösung für z.B: startpage.com fast immer recht lange (was man in der Statuszeile sieht), funktioniert aber (im Gegensatz zu Windows auf diesem HTPC) immer, zumindest laut meinen paar "Versuchen". Es dauert jedenfalls alles deutlich länger als auf meinem Haupt-PC (mit Win10).

Ich habe nun versucht, das mit ping und traceroute etwas zu analysieren.

Anbei ein paar Versuche von meinem HTPC mit Linux (10.0.0.20, "rome").


Dazu auch die Ausgabe von "pihole tail":


Wie man sieht, funktionieren die Domains (z.B. "diewelt.de") immer erst beim zweiten Versuch.

Das vermutlich eigentliche Problem dürfte aber sein, dass der Pi-hole (10.0.0.130) zeitweise "nur schwer erreichbar ist"!
user@rome:~$ date; traceroute 10.0.0.130; date
Mon Mar 25 00:27:51 CET 2019
traceroute to 10.0.0.130 (10.0.0.130), 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * torta (10.0.0.130)  1.120 ms
Mon Mar 25 00:28:01 CET 2019
user@rome:~$
user@rome:~$ date; traceroute 10.0.0.130; date
Mon Mar 25 00:28:36 CET 2019
traceroute to 10.0.0.130 (10.0.0.130), 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * torta (10.0.0.130)  1.020 ms
Mon Mar 25 00:29:01 CET 2019
user@rome:~$
user@rome:~$ date; traceroute 10.0.0.130; date
Mon Mar 25 00:29:20 CET 2019
traceroute to 10.0.0.130 (10.0.0.130), 30 hops max, 60 byte packets
 1  torta (10.0.0.130)  0.580 ms  0.715 ms  0.644 ms
Mon Mar 25 00:29:20 CET 2019

Im "pihole tail" findet sich nur das:
00:28:01 dnsmasq[7323]: query[PTR] 130.0.0.10.in-addr.arpa from 10.0.0.20
00:28:01 dnsmasq[7323]: /etc/pihole/local.list 10.0.0.130 is torta
00:29:01 dnsmasq[7323]: query[PTR] 130.0.0.10.in-addr.arpa from 10.0.0.20
00:29:01 dnsmasq[7323]: /etc/pihole/local.list 10.0.0.130 is torta
00:29:20 dnsmasq[7323]: query[PTR] 130.0.0.10.in-addr.arpa from 10.0.0.20
00:29:21 dnsmasq[7323]: /etc/pihole/local.list 10.0.0.130 is torta

Irgendetwas stimmt hier wohl nicht!
Passt mein Netzwerk-Routing nicht? Und falls ja: Was kann ich da unternehmen?
Oder hängt das irgendwie mit dem Reverse DNS Lookup zusammen?

---

Zum Vergleich auch ein paar Tests von meinem Haupt-PC (Win10), wo alles bestens funktioniert (schnell, DNS-Auflösung immer erfolgreich, Traceroute zum Pi-hole immer sofort mit 1 Hop)!






PS.: Mein Pi-hole heißt "torta", 10.0.0.138
PS2: Die Domains sollten alle noch nicht aufgerufen worden sein, nicht heute oder in den letzten Tagen.

Dieser Beitrag enthält Anhänge.
Bitte anmelden (oder registrieren) um sie zu sehen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Vindobona
  • Vindobonas Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
Mehr
25 Mär 2019 02:02 - 25 Mär 2019 02:03 #77369 von Vindobona
Vindobona antwortete auf DNS, IPv6, Windows und Pi-hole
Und hier die Ausgabe des ARP-Cache.
Mein Pi-hole ist zumindest teilweise STALE (valid but suspicious), was auch immer das bedeutet.
user@rome:~$ ip neigh show
10.0.0.1 dev enp3s0 lladdr xx:xx:xx:bf:d6:a5 DELAY
10.0.0.138 dev enp3s0 lladdr xx:xx:xx:5f:5b:75 DELAY
10.0.0.130 dev enp3s0 lladdr xx:xx:xx:a4:6c:b2 STALE
user@rome:~$
user@rome:~$ date; traceroute 10.0.0.130; date
Mon Mar 25 01:44:28 CET 2019
traceroute to 10.0.0.130 (10.0.0.130), 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * torta (10.0.0.130)  0.794 ms
Mon Mar 25 01:44:38 CET 2019
user@rome:~$
user@rome:~$ ip neigh show
10.0.0.1 dev enp3s0 lladdr xx:xx:xx:bf:d6:a5 REACHABLE
10.0.0.138 dev enp3s0 lladdr xx:xx:xx:5f:5b:75 REACHABLE
10.0.0.130 dev enp3s0 lladdr xx:xx:xx:a4:6c:b2 REACHABLE
user@rome:~$

Ein paar Minuten später ist aber auch mein Gateway (Pirelli, 10.0.0.138) STALE. Das wird also wohl nicht so schlimm sein, vielleicht aber doch.
user@rome:~$ ip neigh show
10.0.0.1 dev enp3s0 lladdr xx:xx:xx:bf:d6:a5 REACHABLE
10.0.0.138 dev enp3s0 lladdr xx:xx:xx:5f:5b:75 STALE
10.0.0.130 dev enp3s0 lladdr xx:xx:xx:a4:6c:b2 STALE


Am Haupt-PC unter Windows sieht das doch ziemlich anders aus. Keine Ahnung, was man damit anfangen kann.
PS C:\> arp -a

Schnittstelle: 10.0.0.1 --- 0x4
  Internetadresse       Physische Adresse     Typ
  10.0.0.20             xx-xx-xx-7e-06-b7     dynamisch
  10.0.0.130            xx-xx-xx-a4-6c-b2     dynamisch
  10.0.0.138            xx-xx-xx-5f-5b-75     dynamisch
  10.0.0.255            ff-ff-ff-ff-ff-ff     statisch
  224.0.0.22            01-00-5e-00-00-16     statisch
  224.0.0.251           01-00-5e-00-00-fb     statisch
  224.0.0.252           01-00-5e-00-00-fc     statisch
  239.2.24.25           01-00-5e-02-18-19     statisch
  239.255.255.250       01-00-5e-7f-ff-fa     statisch
Letzte Änderung: 25 Mär 2019 02:03 von Vindobona.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Moderatoren: andifrm1912enjoyherby68benderrwhomegeko
Ladezeit der Seite: 0.809 Sekunden
Powered by Kunena Forum